accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Newton (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-2189) Document the Repo interface
Date Tue, 14 Jan 2014 14:11:52 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2189?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eric Newton updated ACCUMULO-2189:
----------------------------------

    Description: 
The Repo interface is lacking java doc.  For example:

Repo.isReady return a long and there is no documentation about what its return value should
be and how it is used.

Currently it's used by Fate.run to decide whether to run "Repo.call" or not. If that's the
only purpose it is used for, then isReady should return a boolean. If  we do want it to return
a long, then we should at least use constants by the various derived classes.

  was:
Repo.isReady return a long and there is no documentation about what its return value should
be and how it is used.

Currently it's used by Fate.run to decide whether to run "Repo.call" or not. If that's the
only purpose it is used for, then isReady should return a boolean. If  we do want it to return
a long, then we should at least use constants by the various derived classes.


> Document the Repo interface
> ---------------------------
>
>                 Key: ACCUMULO-2189
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2189
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: docs, fate
>    Affects Versions: 1.7.0
>            Reporter: Vikram Srivastava
>
> The Repo interface is lacking java doc.  For example:
> Repo.isReady return a long and there is no documentation about what its return value
should be and how it is used.
> Currently it's used by Fate.run to decide whether to run "Repo.call" or not. If that's
the only purpose it is used for, then isReady should return a boolean. If  we do want it to
return a long, then we should at least use constants by the various derived classes.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message