accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2160) Run findbugs for 1.6
Date Thu, 09 Jan 2014 00:36:50 GMT


Christopher Tubbs commented on ACCUMULO-2160:

Do we really want PasswordToken to return a copy on getPassword()? Will that violate it's
"Destroyable"-ness in any way (maybe when it's overridden)? I'm not sure. Just want to make
sure we're not doing something we don't want to do.

I also wonder how many of these changes can be represented as warnings in Eclipse (or your
IDE of choosing) and whether we should make them standards. Eclipse may even support some
of these things (like stripping redundant modifiers off interfaces) as save-actions.

Also, I noticed that many changes here added trailing whitespace (including indented blank

In TestLruBlockCache (perhaps elsewhere also), it should probably have used JUnit's Assert.assertArrayEquals(),
for more informative failure messages, rather than assertTrue(Arrays.equals())

It's curious that Math.abs was inline'd into the class. What's the reasoning for that in the

> Run findbugs for 1.6
> --------------------
>                 Key: ACCUMULO-2160
>                 URL:
>             Project: Accumulo
>          Issue Type: Task
>            Reporter: Eric Newton
>            Assignee: Eric Newton
>             Fix For: 1.6.0

This message was sent by Atlassian JIRA

View raw message