accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2126) Hadoop profile names should be consistent across branches
Date Tue, 07 Jan 2014 00:24:52 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2126?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13863692#comment-13863692
] 

ASF subversion and git services commented on ACCUMULO-2126:
-----------------------------------------------------------

Commit 71f150a777f9fb125fd72e51a23b11ed1f48d5c2 in branch refs/heads/1.4.5-SNAPSHOT from [~busbey]
[ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=71f150a ]

ACCUMULO-2126 Hadoop profile names should be consistent across branches.

Changes naming scheme to be by Hadoop generation, i.e. hadoop-1 and hadoop-2.

Adds ability to either rely on default or to specify default by profile, i.e. hadoop.profile=1
on 1.4.

Adds a more helpful error message when the provided hadoop.profile doesn't match one of our
expected options.

Signed-off-by: Mike Drob <mdrob@cloudera.com>


> Hadoop profile names should be consistent across branches
> ---------------------------------------------------------
>
>                 Key: ACCUMULO-2126
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2126
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: build
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Minor
>             Fix For: 1.4.5, 1.5.1, 1.6.0
>
>         Attachments: ACCUMULO-2126.1-1.5.1-SNAPSHOT.patch.txt, ACCUMULO-2126.1-1.6.0-SNAPSHOT.patch.txt,
ACCUMULO-2126.1.patch.txt, ACCUMULO-2126.2-1.5.1-SNAPSHOT.patch.txt, ACCUMULO-2126.2-1.6.0-SNAPSHOT.patch.txt,
ACCUMULO-2126.2.patch.txt, ACCUMULO-2126.3-1.5.1-SNAPSHOT.patch.txt, ACCUMULO-2126.3-1.6.0-SNAPSHOT.patch.txt,
ACCUMULO-2126.3.patch.txt
>
>
> ACCUMULO-1419 changed the hadoop pofile names to reflect the major components used. This
makes documenting how to build against a major hadoop line across all of our branches more
difficult than necessary.
> Since the changes in what we need to do vary with the Hadoop line, e.g. Hadoop 1 and
Hadoop 2, we should name them appropriately.
> Additionally, our current activation scheme for hte default doesn't allow activating
it by name.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message