accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <>
Subject [jira] [Updated] (ACCUMULO-2126) Hadoop profile names should be consistent across branches
Date Mon, 06 Jan 2014 21:03:50 GMT


Sean Busbey updated ACCUMULO-2126:

    Attachment: ACCUMULO-2126.2.patch.txt

Updated patch(es) per Mike's feedback.

 * removed trailing whitespace from impacted lines
 * updated comments to say Hadoop 1.x and 2.x
 * added enforcer line to give feedback about invalid profile numbers

> Hadoop profile names should be consistent across branches
> ---------------------------------------------------------
>                 Key: ACCUMULO-2126
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: build
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Minor
>             Fix For: 1.4.5, 1.5.1, 1.6.0
>         Attachments: ACCUMULO-2126.1-1.5.1-SNAPSHOT.patch.txt, ACCUMULO-2126.1-1.6.0-SNAPSHOT.patch.txt,
ACCUMULO-2126.1.patch.txt, ACCUMULO-2126.2-1.5.1-SNAPSHOT.patch.txt, ACCUMULO-2126.2-1.6.0-SNAPSHOT.patch.txt,
> ACCUMULO-1419 changed the hadoop pofile names to reflect the major components used. This
makes documenting how to build against a major hadoop line across all of our branches more
difficult than necessary.
> Since the changes in what we need to do vary with the Hadoop line, e.g. Hadoop 1 and
Hadoop 2, we should name them appropriately.
> Additionally, our current activation scheme for hte default doesn't allow activating
it by name.

This message was sent by Atlassian JIRA

View raw message