accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <>
Subject [jira] [Updated] (ACCUMULO-2126) Hadoop profile names should be consistent across branches
Date Fri, 03 Jan 2014 20:52:50 GMT


Sean Busbey updated ACCUMULO-2126:

    Attachment: ACCUMULO-2126.1-1.6.0-SNAPSHOT.patch.txt

patches to unify our hadoop profiles across active dev. since there are conflicts across each
merge, it's easiest just to rely on the patches to provide changes.

tested by building against default and specified 1 and 2 on all three branches.


# these instructions presume all branches are up-to-date wrt remote
# after normal contribution review on 1.4.5-SNAPSHOT
$> git am --signoff < ACCUMULO-2126.1.patch.txt
# do testing on 1.4.5-SNAPSHOT
$> git checkout 1.5.1-SNAPSHOT
$> git merge -s ours --no-commit 1.4.5-SNAPSHOT
$> patch -p1 < ACCUMULO-2126.1-1.5.1-SNAPSHOT.patch.txt
# add and review changes in merge
$> git add -p *
$> git commit
# do testing on 1.5.1-SNAPSHOT
$> git checkout 1.6.0-SNAPSHOT
$> git merge -s ours --no-commit 1.5.1-SNAPSHOT
$> patch -p1 < ACCUMULO-2126.1-1.6.0-SNAPSHOT.patch.txt
# add and review changes in merge
$> git add -p *
$> git commit
# do testing on 1.6.0-SNAPSHOT
$> git checkout master
# merge to master should be clean
$> git merge 1.6.0-SNAPSHOT
# do testing on master
# push to remote
$> git push origin 1.4.5-SNAPSHOT 1.5.1-SNAPSHOT 1.6.0-SNAPSHOT master

> Hadoop profile names should be consistent across branches
> ---------------------------------------------------------
>                 Key: ACCUMULO-2126
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: build
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Minor
>             Fix For: 1.4.5, 1.5.1, 1.6.0
>         Attachments: ACCUMULO-2126.1-1.5.1-SNAPSHOT.patch.txt, ACCUMULO-2126.1-1.6.0-SNAPSHOT.patch.txt,
> ACCUMULO-1419 changed the hadoop pofile names to reflect the major components used. This
makes documenting how to build against a major hadoop line across all of our branches more
difficult than necessary.
> Since the changes in what we need to do vary with the Hadoop line, e.g. Hadoop 1 and
Hadoop 2, we should name them appropriately.
> Additionally, our current activation scheme for hte default doesn't allow activating
it by name.

This message was sent by Atlassian JIRA

View raw message