accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Fri, 10 Jan 2014 17:52:52 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13868038#comment-13868038
] 

Josh Elser commented on ACCUMULO-2061:
--------------------------------------

Ok, that's what I typically expected when I hear relative paths in the context of 1.6, but
when dealing with the configuration of these parameters, it wasn't clear to me.

So what exactly needs to be decided here? Is deprecating instance.dfs.dir and instance.dfs.uri
definitely what we want to do for 1.6? It looks like instance.volumes defaults to "" presently
which doesn't jive with what Christopher said earlier about defaulting to "/accumulo" -- should
this be updated?

As of now, it looks like the "default" volume is still pulled only from instance.dfs.dir (will
error if you try it through instance.volumes) and instance.volumes is used for additional
volume definitions.

> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>
>                 Key: ACCUMULO-2061
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2061
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>             Fix For: 1.6.0
>
>
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
property.
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode
URIs".



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message