accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Fri, 10 Jan 2014 17:26:52 GMT


Keith Turner commented on ACCUMULO-2061:

[~elserj] I am usually thinking of a suffix of the path portion when I mention relative paths.
  If a file for a tablet is stored in {{hdfs://foo1:9000/accumulo_test/tables/9/t-003/}},
then prior to 1.6 a tablet would keep track of {{t-003/}} (or {{../9/t-003/}}
if were a cloned table).  This is what I usually mean by relative path.   Prior to 1.6 we
would take t-003/ and put that together with fs uri (from hadoop or accumulo config),
accumulo dir (from accumulo config), the table dir constant, and table id (from tablet metadata)
to produce a location.  Actually the I am using relative path a little more generally, because
it also refers to the process needed to resolve walogs paths. For tablets and walogs we switched
from late binding to early binding for new paths.  Paths created in older releases are still
resolved using late binding.  

> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>                 Key: ACCUMULO-2061
>                 URL:
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>             Fix For: 1.6.0
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode

This message was sent by Atlassian JIRA

View raw message