accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Wed, 15 Jan 2014 02:31:20 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13871550#comment-13871550
] 

Christopher Tubbs commented on ACCUMULO-2061:
---------------------------------------------

[~elserj] wrote:

{quote}So what exactly needs to be decided here?{quote}

# instance.dfs.uri is certainly unnecessary outside of upgrades, only needed for resolving
the previous relative paths. We can deprecate its use now... no deciding necessary.
# instance.dfs.dir is needed to resolve the previous relative paths, but also (currently)
as a (in my view) confusing extra element for each volume in instance.volumes... we need to
decide if we want it to only be used for resolving the previous relative paths.

Do we agree that the extra element adds little value as a separate property and is really
only needed to resolve relative paths from previous versions?.... OR... do we think that it's
useful to configure a common subdirectory with a separate property and that this warrants
keeping the current behavior of joining two properties to make absolute paths?

Personally, if we think there's any value in configuring a common subdirectory, i think we
can support that feature by adding property interpolation in configuration parsing in the
future. Example:
{code}
subdir = myApplication.accumulo-files
instance.volumes = hdfs://nn1/${subdir},hdfs://nn2/${subdir}
{code}

However, while interpolation is a useful feature... I don't think it's a prerequisite for
solidifying the behavior of absolute paths with a single property rather than two.

> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>
>                 Key: ACCUMULO-2061
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2061
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>             Fix For: 1.6.0
>
>
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
property.
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode
URIs".



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message