accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Havanki (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1944) Cobertura not working for functional tests in 1.5.x and earlier
Date Mon, 06 Jan 2014 20:02:50 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1944?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13863339#comment-13863339
] 

Bill Havanki commented on ACCUMULO-1944:
----------------------------------------

Thanks for the feedback, Josh! I had made two separate patches, one for 1.4 and another for
1.5. So, you are correct, I applied both. I can understand that they come out as duplicates
since 1.4 gets merged into 1.5 during the process. That merge piece was something I didn't
really get until [~mdrob] explained it today.

Next time, I'll try to resolve it during the merge. That makes a lot of sense now. Thanks
again! :)

> Cobertura not working for functional tests in 1.5.x and earlier
> ---------------------------------------------------------------
>
>                 Key: ACCUMULO-1944
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1944
>             Project: Accumulo
>          Issue Type: Bug
>          Components: test
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Bill Havanki
>            Assignee: Bill Havanki
>              Labels: cobertura, testing
>             Fix For: 1.4.5, 1.5.1
>
>         Attachments: ACCUMULO-1944-1.4.patch, ACCUMULO-1944-1.4.v2.patch, ACCUMULO-1944-1.5.patch,
ACCUMULO-1944-1.5.v2.patch
>
>
> The -C argument to test/system/auto/run.py should enable running instrumented functional
tests to analyze coverage using Cobertura. The capability is not functional; code is not instrumented
even when Cobertura is available, and tests are not run with the instrumented code.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message