accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vikram Srivastava (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-80) Refactor ScannerOptions to just use a map of iterators
Date Tue, 14 Jan 2014 08:48:56 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-80?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13870528#comment-13870528
] 

Vikram Srivastava commented on ACCUMULO-80:
-------------------------------------------

While doing the refactoring, we should also make the iterator map private. Derived classes
should access them through getters.

> Refactor ScannerOptions to just use a map of iterators
> ------------------------------------------------------
>
>                 Key: ACCUMULO-80
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-80
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client, tserver
>            Reporter: Jesse Yates
>
> Based on comments in ACCUMULO-53 ScannerOptions should be refactored to just having a
Map<String, IteratorSetting> mapping iterator names to iterator settings, instead of
a list and a map<scope, options>. This makes it really easy for people to add/remove
iterators.
> This involves a change to the thrift interface as well as in ScannerBase and the server
side reading of the map. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message