accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2114) default namesapce name should be part of the public api
Date Tue, 31 Dec 2013 01:57:50 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2114?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13859253#comment-13859253
] 

Christopher Tubbs commented on ACCUMULO-2114:
---------------------------------------------

In what way do you propose users interact with this value? The way it is currently implemented
is similar to java classes in the default package. That is, the fully qualified table names
for tables in the default namespace have no namespace prefix. Namespaces are not really first
class citizens, like tables. So, can you clarify how you think this should change?

> default namesapce name should be part of the public api
> -------------------------------------------------------
>
>                 Key: ACCUMULO-2114
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2114
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: John Vines
>             Fix For: 1.6.0
>
>
> The name of the default namespace currently lives in org.apache.accumulo.client.impl.Namespaces
which is not part of the public api. We should make this variable part of the public API to
make it easier for users to interact with namespaces.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message