accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-2047) Failures when using two namenodes and viewfs://
Date Wed, 18 Dec 2013 03:18:07 GMT
Keith Turner created ACCUMULO-2047:
--------------------------------------

             Summary: Failures when using two namenodes and viewfs://
                 Key: ACCUMULO-2047
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2047
             Project: Accumulo
          Issue Type: Bug
            Reporter: Keith Turner
            Assignee: Keith Turner
             Fix For: 1.6.0


I was trying to use viewfs:// with hadoop 2.2.0 and two namenodes.  I saw multiple failures
when trying to do this.   I will open subtickets for specific failures.

I had the following in my hadoop core-site.xml

{noformat}
<configuration>
  <property>
    <name>fs.default.name</name>
    <value>viewfs:///</value>
  </property>
  <property>
    <name>fs.viewfs.mounttable.default.link./nn1</name>
    <value>hdfs://ip-10-1-3-10:9000</value>
  </property>
  <property>
    <name>fs.viewfs.mounttable.default.link./nn2</name>
    <value>hdfs://ip-10-1-3-11:9000</value>
  </property>
</configuration>
{noformat}

I had the following in my accumulo-site.xml

{noformat}
  <property>
    <name>instance.volumes</name>
    <value>viewfs:///nn1,viewfs:///nn2</value>
  </property>
{noformat}



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message