accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Havanki (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1944) Cobertura not working for functional tests in 1.5.x and earlier
Date Mon, 02 Dec 2013 20:32:36 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1944?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13836881#comment-13836881
] 

Bill Havanki commented on ACCUMULO-1944:
----------------------------------------

I had success with it last week, so I don't mind submitting changes. I bet the overall technique
will be similar for any tests that use the Cobertura scripts instead of the Maven plugin.
Those scripts were also broken (in Cobertura 2.0.x), so I have hopefully repaired those as
well (submitted a pull request for it, will link to this ticket).

> Cobertura not working for functional tests in 1.5.x and earlier
> ---------------------------------------------------------------
>
>                 Key: ACCUMULO-1944
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1944
>             Project: Accumulo
>          Issue Type: Bug
>          Components: test
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Bill Havanki
>            Assignee: Bill Havanki
>              Labels: cobertura, testing
>
> The -C argument to test/system/auto/run.py should enable running instrumented functional
tests to analyze coverage using Cobertura. The capability is not functional; code is not instrumented
even when Cobertura is available, and tests are not run with the instrumented code.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message