accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Newton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1944) Cobertura not working for functional tests in 1.5.x and earlier
Date Mon, 02 Dec 2013 16:39:37 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1944?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13836670#comment-13836670
] 

Eric Newton commented on ACCUMULO-1944:
---------------------------------------

I have not tried to run coverage for a long time.  The last time I did, it was painfully slow,
with many false failures due to timing issues.  I discourage you from putting any time into
fixing this in the python test driver since it no longer exists.  Instead, I would put the
effort into getting coverage to work for the integration tests.


> Cobertura not working for functional tests in 1.5.x and earlier
> ---------------------------------------------------------------
>
>                 Key: ACCUMULO-1944
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1944
>             Project: Accumulo
>          Issue Type: Bug
>          Components: test
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Bill Havanki
>            Assignee: Bill Havanki
>              Labels: cobertura, testing
>
> The -C argument to test/system/auto/run.py should enable running instrumented functional
tests to analyze coverage using Cobertura. The capability is not functional; code is not instrumented
even when Cobertura is available, and tests are not run with the instrumented code.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message