accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Allen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1852) nativeMap test doesn't run on OS X
Date Thu, 05 Dec 2013 17:00:38 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1852?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13840274#comment-13840274
] 

Michael Allen commented on ACCUMULO-1852:
-----------------------------------------

It was definitely just the basic 'make test' part that was failing for me.  On my Mac, for
whatever reason, I do not have /System/Library/Frameworks/JavaVM.framework/Headers as a directory,
so I'm not surprised it didn't work.  I am running 1.7.0_45.

> nativeMap test doesn't run on OS X
> ----------------------------------
>
>                 Key: ACCUMULO-1852
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1852
>             Project: Accumulo
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.6.0
>         Environment: Mac OS X Mavericks
>            Reporter: Michael Berman
>            Assignee: Christopher Tubbs
>             Fix For: 1.6.0
>
>         Attachments: 0001-ACCUMULO-1852-Further-fixes-nativemap-test-on-OSX.patch, ACCUMLUO-1852.patch
>
>
> The Makefile has bad includes for the test run, but even when I fix that, it still fails
looking like it's not linking stdc++ properly.  [~elserj] and I both looked at it for a bit
and couldn't make it work.
> Since I last saw it succeed, I have both updated to Mavericks and merged in the change
to have the pom manage make.
> I also haven't seen NativeMapIT pass since the updates, so I'm wondering if it's not
just the test execution that's broken, but also the actual nativemap build.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message