accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ACCUMULO-1593) Looking up instanceName in ZK doesn't use consistent encoding
Date Fri, 20 Dec 2013 05:13:07 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-1593?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Josh Elser resolved ACCUMULO-1593.
----------------------------------

    Resolution: Fixed

Thanks, [~yuzhihong@gmail.com]! I had to mess with your patch a little bit due to the time
delay. Sorry it took so long to get it applied -- looks like it just got lost in the breeze.

> Looking up instanceName in ZK doesn't use consistent encoding
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-1593
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1593
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Christopher Tubbs
>            Assignee: Ted Yu
>              Labels: newbie
>             Fix For: 1.4.5, 1.5.1, 1.6.0
>
>         Attachments: accumulo-1593-v1.txt, accumulo-1593-v2.txt
>
>
> We need to be more careful about encoding and decoding instance names and IDs in zookeeper.
They should use UTF-8 explicitly, right now, they use the JVM default, which can differ between
JVM runs (even between Initialize and start-all).



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message