accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Wall (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1876) Problem using accumulo artifacts from ivy
Date Wed, 13 Nov 2013 00:37:17 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1876?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13820741#comment-13820741
] 

Michael Wall commented on ACCUMULO-1876:
----------------------------------------

[~elserj] hmm, not sure why hadoop.version http.client version weren't causing issues.  I
see you fixed them as well.  Thanks man.

Oh, and ivy was not caching the files maven already cached.  I had ivy reading from the local
maven repo so we "mvn install" a fix and test it.  Normally, you wouldn't need that and could
just pretend that maven didn't exist :)  

> Problem using accumulo artifacts from ivy
> -----------------------------------------
>
>                 Key: ACCUMULO-1876
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1876
>             Project: Accumulo
>          Issue Type: Bug
>          Components: master
>    Affects Versions: 1.5.0
>            Reporter: Michael Wall
>            Assignee: Michael Wall
>            Priority: Minor
>             Fix For: 1.5.1, 1.6.0
>
>         Attachments: 1876-1.5.1-SNAPSHOT.patch, 1876-1.6.0-SNAPSHOT.patch, 1876.patch,
accumulo-slf4j-bug.tar.gz
>
>
> Defining an accumulo dependency in an ivy.xml file for any Accyumulo version greater
than 1.4.4 results in the following error 
> {noformat}
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 		::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 		:: org.slf4j#slf4j-api;${slf4j.version}: not found
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 
> {noformat}
> The issue appears to be that in the parent pom.xml, slf4j.version is only defined in
profiles.  Ivy doesn't load profiles when pulling from a maven repo, so the ${slf4j.version}
is never set.
> One possible fix is to define a property earlier with the version, and allow the profiles
to overwrite.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message