accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Havanki (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-1873) start-all.sh's zookeeper version check is lacking
Date Fri, 15 Nov 2013 15:37:23 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-1873?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bill Havanki updated ACCUMULO-1873:
-----------------------------------

    Status: Patch Available  (was: In Progress)

Try this patch (based on 1.4.5-SNAPSHOT).

> start-all.sh's zookeeper version check is lacking
> -------------------------------------------------
>
>                 Key: ACCUMULO-1873
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1873
>             Project: Accumulo
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 1.5.0, 1.4.4
>            Reporter: Josh Elser
>            Assignee: Bill Havanki
>            Priority: Minor
>             Fix For: 1.4.5, 1.5.1, 1.6.0
>
>         Attachments: ACCUMULO-1873.patch
>
>
> If ZOOKEEPER_HOME is defined (in the current env or in accumul-env.sh) but it's pointing
at somewhere that doesn't contain a zookeeper-x.y.z.jar (e.g. ZOOKEEPER_HOME isn't actually
pointing to a ZooKeeper installation), the zookeeper version check will end up returning an
empty string which will cause an inaccurate warning to be printed.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message