accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joey Echeverria (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1793) Update Hadoop 2.0 profile to Hadoop 2.2.0
Date Wed, 27 Nov 2013 16:26:38 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1793?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13833916#comment-13833916
] 

Joey Echeverria commented on ACCUMULO-1793:
-------------------------------------------

Honestly, I'm surprised we advanced 1.5.1-SNAPSHOT to Hadoop 1.2.1. I always viewed the default
version (and profile) to represent the lowest version that we're maintaining compatability
with. That means that I'd fully expect that version to change between 1.4, 1.5, and 1.6 since
I would think that became fixed at the time the major version was released. I would only advance
the Hadoop version if there was a known issue with what we had previously declared the lowest
compatable version.

Recommendations for which version to use at a minimum should be made in documentation, not
the POM file, in my opinion. The POM file should focus on declaring compatability, not necessarily
recommending a best practice.

> Update Hadoop 2.0 profile to Hadoop 2.2.0
> -----------------------------------------
>
>                 Key: ACCUMULO-1793
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1793
>             Project: Accumulo
>          Issue Type: Sub-task
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>         Attachments: 0001-ACCUMULO-1793-Changes-that-to-make-semi-sane-build-p.patch,
ACCUMULO-1793.1.patch.txt
>
>
> now that Hadoop 2 has a GA release, update the Hadoop 2.0 profile to target it.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message