accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1792) Backport changes for Hadoop 2.0 from 1.5 to 1.4
Date Tue, 26 Nov 2013 02:05:36 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1792?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13832193#comment-13832193
] 

Sean Busbey commented on ACCUMULO-1792:
---------------------------------------

[~ecn], did you clean up your working directory before building? The line that is failing
references o.a.a.core.Constants.METADATA_TABLET_COLUMN_FAMILY. That field exists in 1.4.x,
but does not in 1.6.0-SNAPSHOT+. So it looks like your classpath is getting a 1.6.x version
of that file and a 1.4.x version of o.a.a.server.util.Initialize.

Could you try running `git clean -xdf` and then rebuilding and rerunning?

Also note that as of the patch attached, building requires specifying both the hadoop profile
and the hadoop version:

{code}
  $> mvn -Dhadoop.profile=2.0 -Dhadoop.version=2.2.0 clean package && mvn -Dhadoop.profile=2.0
-Dhadoop.version=2.2.0 assembly:single -N
{code}

> Backport changes for Hadoop 2.0 from 1.5 to 1.4
> -----------------------------------------------
>
>                 Key: ACCUMULO-1792
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1792
>             Project: Accumulo
>          Issue Type: Sub-task
>    Affects Versions: 1.4.4
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>         Attachments: ACCUMULO-1792.1.patch.txt, ACCUMULO-1792.2.patch.txt
>
>
> work against this sub-task need not worry about Hadoop 0.20 compatibility, which will
be handled in a follow on jira.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message