accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Newton (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ACCUMULO-1805) Accumulo "execute command" oddity
Date Wed, 23 Oct 2013 14:33:41 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-1805?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eric Newton resolved ACCUMULO-1805.
-----------------------------------

    Resolution: Cannot Reproduce
      Assignee: Eric Newton

{noformat}
./bin/accumulo shell  -u root -e "tables -l"
{noformat}

Works just fine for me.  If you are doing something with the {{!METADATA}} table, you'll have
to use single quotes to escape the exclamation mark.


> Accumulo "execute command" oddity
> ---------------------------------
>
>                 Key: ACCUMULO-1805
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1805
>             Project: Accumulo
>          Issue Type: Bug
>          Components: shell
>    Affects Versions: 1.5.0
>            Reporter: Eric Newton
>            Assignee: Eric Newton
>
> Roshan Punnoose writes:
> {quote}
> Running Accumulo 1.5, I noticed that the "--execute-command" option does not work for
any command with spaces.
> This command works fine:
> accumulo shell -u root -e "tables"
> But this command fails: 
> accumulo shell -u root -e "tables -l"
> With: [shell.Shell] ERROR: org.apache.commons.cli.MissingArgumentException: Missing argument
for option: l
> Looks like JCommander cannot parse the string? Should I use something other than double
quotes?
> {quote}



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message