accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Vines (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1592) Remove static method "lookupInstanceName(ZooCache, UUID)" from public API
Date Mon, 28 Oct 2013 23:28:30 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1592?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13807465#comment-13807465
] 

John Vines commented on ACCUMULO-1592:
--------------------------------------

Not sure if it makes sense to remove it because it is used by HDFSZooinstance and by the ZooKeeperInstances
which take in a UUID as a constructor. It's the same code so it doesn't make sense to copy
it around. However, I think it would behoove us to find a better way to indicate it's not
part of the client API than just deprecating it.

> Remove static method "lookupInstanceName(ZooCache, UUID)" from public API
> -------------------------------------------------------------------------
>
>                 Key: ACCUMULO-1592
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1592
>             Project: Accumulo
>          Issue Type: Improvement
>    Affects Versions: 1.5.0
>            Reporter: Christopher Tubbs
>            Assignee: John Vines
>             Fix For: 1.6.0
>
>
> In 1.5, this method was deprecated, because ZooCache was moved from the core package
to the fate package. I removed that deprecated method, but I'm not sure why lookupInstanceName(...)
exists in ZooKeeperInstance in the first place, especially since ZooCache is really an internal
thing.
> I think this method should be removed (read: deprecated, for now; remove in 1.7 or later)
from the ZooKeeperInstance class (if it's still needed, it should be moved to a utility class).



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message