accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Corey J. Nolet (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-391) Multi-table Accumulo input format
Date Tue, 24 Sep 2013 17:16:02 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13776500#comment-13776500
] 

Corey J. Nolet commented on ACCUMULO-391:
-----------------------------------------

bq. Something appears to be adding a space between a method name and the parenthesis,

I'm using a new version of intelli-j and a I got a new mac book pro recently. Once upon a
time I had the Eclipse codestyle plugin installed and I seemed to have tweaked it correctly-
though it looks like I need to do that on this new system. I just noticed the space between
the parens. I'll have to look in the intelli-j settings to figure out why that happened.

bq. instead of just InputFormatBase, changing calls to this method from AccumuloInputFormat.addIterator
to just addIterator. I found this to be confusing.

I've been habitually importing static methods to make the code easier to read but I can change
that back easily if it's confusing.

[~kturner] I'll make the changes you requested and work on ticket ACCUMULO-1732 before merging
the multi-table import format.
                
> Multi-table Accumulo input format
> ---------------------------------
>
>                 Key: ACCUMULO-391
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-391
>             Project: Accumulo
>          Issue Type: New Feature
>            Reporter: John Vines
>            Assignee: Corey J. Nolet
>            Priority: Minor
>              Labels: mapreduce,
>             Fix For: 1.6.0
>
>         Attachments: ACCUMULO-391.patch, multi-table-if.patch, new-multitable-if.patch
>
>
> Just realized we had no MR input method which supports multiple Tables for an input format.
I would see it making the table the mapper's key and making the Key/Value a tuple, or alternatively
have the Table/Key be the key tuple and stick with Values being the value.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message