accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1602) put the KeyExtent in a major compactors' thread name for easier debugging
Date Tue, 23 Jul 2013 20:42:48 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1602?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13717584#comment-13717584
] 

Mike Drob commented on ACCUMULO-1602:
-------------------------------------

I am not a fan of a utility that, in essence, is running a brute force attack on the hash
that we're trying to find. This also puts up a huge barrier to the usefulness of the naming.


Why are we even worrying about this? Is there a max length to thread names that we need to
fit in?


What are the semantics for automatic expansion in a range compaction? Does it include the
whole row? The whole tablet? Is this part of the API contract and specified in the docs, or
is it simply a side-effect of the implementation?
                
> put the KeyExtent in a major compactors' thread name for easier debugging
> -------------------------------------------------------------------------
>
>                 Key: ACCUMULO-1602
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1602
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: tserver
>            Reporter: Eric Newton
>            Priority: Minor
>              Labels: newbie
>             Fix For: 1.6.0
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message