accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1337) Create Whole Column Family Iterator
Date Fri, 26 Apr 2013 13:52:15 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1337?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13642853#comment-13642853
] 

Keith Turner commented on ACCUMULO-1337:
----------------------------------------

I justt ok a look at patch v1.

 * class javadoc should go before class, not before imports
 * maybe rename static function decodeRow() to decodeColumnFamily()?
 * should probably implement OptionDescriber... unless the configuring an iterator in the
shell no longer requires this.  I noticed the WholeRowIterator does not implement this also.
 * decodeRow()/decodeColumnFamily() should really have javadoc, since its user facing... this
appears to be an issue w/ the WholeRowIterator
 * We have started adding since javadoc tags... this entire class could have a @since 1.6.0
tag in the javadoc
 * should the javadoc for filter change?  seems its still oriented twoard rows?  
 * might consider a unit test for deepCopy()

Curious about the history behind testBug1() was this something you ran into w/ using the iterator
w/ multiple tablets?  At first the test threw me off because I did not notice the MultiIterator
was narrowing the range.

I looked at the diffs between the WholeRowIterator and WholeColumnFamilyIterator.  The code
for both are so short and the diffs significant enough that I am not sure if it makes sense
to generalize the code.   It seems like it would only make sense to do this if it makes maintenance
easier and reduces bugs.  If creating a generalized super class is more complex and makes
maintenance harder, then its probably not worthwhile.  What do you think?
                
> Create Whole Column Family Iterator
> -----------------------------------
>
>                 Key: ACCUMULO-1337
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1337
>             Project: Accumulo
>          Issue Type: New Feature
>          Components: tserver
>            Reporter: Pushpinder Heer
>            Assignee: Keith Turner
>            Priority: Trivial
>         Attachments: ACCUMULO-1337_v1.patch
>
>
> Add similar functionality as WholeRowIterator, but group by row/cf.  WholeColumnFamilyIterator.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message