accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Vines (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1321) Dynamic Classloader lost jars
Date Mon, 29 Apr 2013 20:02:16 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1321?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13644807#comment-13644807
] 

John Vines commented on ACCUMULO-1321:
--------------------------------------

I've also been looking into this issue and I'm reaching the same
conclusion. I didn't get as far as you, but I did see that the Resource is
was finding was different then the actual file. Have you done research on
the issues with recreating the VFS?



                
> Dynamic Classloader lost jars
> -----------------------------
>
>                 Key: ACCUMULO-1321
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1321
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: John Vines
>            Assignee: Keith Turner
>             Fix For: 1.5.0
>
>
> We have a table setup that uses some custom iterators. We ran an MR job against it without
issues. We then ran the job immediately after the first one wrapped and 2 of my tservers errored
with ClassNotFoundException, even though it ran just fine before.
> Unfortunately we don't have a stack trace (to see if it was breaking differently in the
VFSClassLoader), nor a convenient way to recreate currently. We're working on reproducing
it in order to get more information.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message