accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-1209) Client cannot get tablet info for unknown reason
Date Tue, 26 Mar 2013 18:45:15 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-1209?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mike Drob updated ACCUMULO-1209:
--------------------------------

    Description: 
When attempting a map reduce over a table, I got the warning {{Unable to locate bins for specified
ranges. Retrying.}} from {{InputFormatBase}}. It would keep retrying until I got bored and
killed the job, never finding the correct bins.

I logged in to the Accumulo shell and was able to fully scan the {{!METADATA}} table without
a problem. However, when I try to scan my data table (id: a), I saw the following messages
repeated with debug on:
{noformat}
[impl.MetadataLocationObtainer] TRACE: tid=11 oid=7  Looking up in !0 row=a; extent=!0;~;!0<
tserver=[ip address]:9997
[impl.MetadataLocationObtainer] TRACE: tid=11 oid=7  Got 0 results from !0;~;!0< in 1.003
secs
[impl.TabletLocatorImpl] TRACE: tid=11 oid=4  Located tablet null at null in 1.058 secs
[impl.ThriftScanner] DEBUG: Failed to locate tablet for table : a row :
{noformat}


I was able to work around this problem by cloning the table and using the cloned version.

  was:
When attempting a map reduce over a tablet, I got the warning {{Unable to locate bins for
specified ranges. Retrying.}} from {{InputFormatBase}}. It would keep retrying until I got
bored and killed the job, never finding the correct bins.

I logged in to the Accumulo shell and was able to fully scan the {{!METADATA}} table without
a problem. However, when I try to scan my data table (id: a), I saw the following messages
repeated with debug on:
{noformat}
[impl.MetadataLocationObtainer] TRACE: tid=11 oid=7  Looking up in !0 row=a; extent=!0;~;!0<
tserver=[ip address]:9997
[impl.MetadataLocationObtainer] TRACE: tid=11 oid=7  Got 0 results from !0;~;!0< in 1.003
secs
[impl.TabletLocatorImpl] TRACE: tid=11 oid=4  Located tablet null at null in 1.058 secs
[impl.ThriftScanner] DEBUG: Failed to locate tablet for table : a row :
{noformat}


I was able to work around this problem by cloning the table and using the cloned version.

    
> Client cannot get tablet info for unknown reason
> ------------------------------------------------
>
>                 Key: ACCUMULO-1209
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1209
>             Project: Accumulo
>          Issue Type: Bug
>          Components: master, tserver
>    Affects Versions: 1.4.2
>            Reporter: Mike Drob
>            Assignee: Eric Newton
>
> When attempting a map reduce over a table, I got the warning {{Unable to locate bins
for specified ranges. Retrying.}} from {{InputFormatBase}}. It would keep retrying until I
got bored and killed the job, never finding the correct bins.
> I logged in to the Accumulo shell and was able to fully scan the {{!METADATA}} table
without a problem. However, when I try to scan my data table (id: a), I saw the following
messages repeated with debug on:
> {noformat}
> [impl.MetadataLocationObtainer] TRACE: tid=11 oid=7  Looking up in !0 row=a; extent=!0;~;!0<
tserver=[ip address]:9997
> [impl.MetadataLocationObtainer] TRACE: tid=11 oid=7  Got 0 results from !0;~;!0< in
1.003 secs
> [impl.TabletLocatorImpl] TRACE: tid=11 oid=4  Located tablet null at null in 1.058 secs
> [impl.ThriftScanner] DEBUG: Failed to locate tablet for table : a row :
> {noformat}
> I was able to work around this problem by cloning the table and using the cloned version.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message