accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-1130) Rename SecurityToken to AuthenticationToken
Date Tue, 26 Mar 2013 22:39:15 GMT


Christopher Tubbs commented on ACCUMULO-1130:

The plurality was changed to match grammatical norms, only because it was also named with
the "T" prefix, to distinguish it as a thrift object in the same refactoring, following the
conventions of all our other thrift code. This naming convention is very convenient to developers,
to easily recognize and avoid putting RPC objects in the public API, and for constraining
RPC objects to RPC-related code (this will help us in the future, for instance when, if ever
ACCUMULO-756 is completed, so our RPC can be made more pluggable and modular). I wouldn't
have made the change if it was only the singular/plural. It was incidental to the "T" prefix

As for the non-thrift Credential object, well, I've previously expressed my concern and stated
that early serialization to RPC objects in our client code prevents users from exercising
the Destroyable interface of the Tokens. This class satisfies that case by wrapping the token
without serializing it, so if it is destroyed at any point in the client code, it will be
invalidated for any subsequent RPC calls (as Destroyable implies it should be). Essentially,
the point is to confine thrift objects to RPC code, and to avoid it spreading throughout our
client code and introducing bugs (because thrift objects have a lot of methods and its easy
to call the wrong ones, or by calling them with assumptions of state that shouldn't be assumed).
> Rename SecurityToken to AuthenticationToken
> -------------------------------------------
>                 Key: ACCUMULO-1130
>                 URL:
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>             Fix For: 1.5.0
> "SecurityToken" is pretty generic and ambiguous for what it is intended to be used for.
"AuthenticationToken" is a better name.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message