accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Vines (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-1130) Rename SecurityToken to AuthenticationToken
Date Tue, 26 Mar 2013 22:17:15 GMT


John Vines commented on ACCUMULO-1130:

The question is why. It seems like unnecessary complexity. They are outside of user scope,
nothing in core alters them outside of the helper methods used to create them, and the only
thing in server that edits them are in the security scope. Translating to and from thrift
objects is unnecessarily complex for something that gets transparently passed through most
> Rename SecurityToken to AuthenticationToken
> -------------------------------------------
>                 Key: ACCUMULO-1130
>                 URL:
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>             Fix For: 1.5.0
> "SecurityToken" is pretty generic and ambiguous for what it is intended to be used for.
"AuthenticationToken" is a better name.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message