accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1130) Rename SecurityToken to AuthenticationToken
Date Tue, 26 Mar 2013 22:13:15 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1130?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13614611#comment-13614611
] 

Christopher Tubbs commented on ACCUMULO-1130:
---------------------------------------------

[~vines] Without a commit number I can't give a detailed explanation, but I would have changed
"Credential" changed to "TCredentials", following the naming convention of other thrift objects,
and making it plural to conform with grammatical norms. I've created a separate Credentials
object for non-thrift use, but haven't worked it into the code yet.
                
> Rename SecurityToken to AuthenticationToken
> -------------------------------------------
>
>                 Key: ACCUMULO-1130
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1130
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>             Fix For: 1.5.0
>
>
> "SecurityToken" is pretty generic and ambiguous for what it is intended to be used for.
"AuthenticationToken" is a better name.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message