accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pete Carlson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-916) Accumulo branch 1.4.0 from SVN won't build with maven
Date Wed, 19 Dec 2012 17:11:13 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-916?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13536140#comment-13536140
] 

Pete Carlson commented on ACCUMULO-916:
---------------------------------------

I tried cygwin also, but I get another error with a build.sh script.

Here was my try with mvn clean package under the parent:

{noformat}
Nik@PTech-Mobile /cygdrive/c/Users/Public/eclipse_workspace/accumulo_1.4.0_tag
$ ll
-bash: ll: command not found

Nik@PTech-Mobile /cygdrive/c/Users/Public/eclipse_workspace/accumulo_1.4.0_tag
$ ls -l
total 144
drwxrwxrwx+ 1 Nik None     0 Dec 19 10:46 bin
-rwxrwxrwx+ 1 Nik None 17728 Dec 19 10:46 CHANGES
drwxrwxrwx+ 1 Nik None     0 Dec 19 10:45 conf
drwxrwxrwx+ 1 Nik None     0 Dec 19 10:45 contrib
drwxrwxrwx+ 1 Nik None     0 Dec 19 10:46 docs
drwxrwxrwx+ 1 Nik None     0 Dec 19 11:56 lib
-rwxrwxrwx+ 1 Nik None 57502 Dec 19 10:45 LICENSE
-rwxrwxrwx+ 1 Nik None  2139 Dec 19 10:45 NOTICE
-rwxrwxrwx+ 1 Nik None 28314 Dec 19 10:46 pom.xml
-rwxrwxrwx+ 1 Nik None 13506 Dec 19 10:46 README
drwxrwxrwx+ 1 Nik None     0 Dec 19 10:46 src
drwxrwxrwx+ 1 Nik None     0 Dec 19 12:06 target
drwxrwxrwx+ 1 Nik None     0 Dec 19 10:45 test

Nik@PTech-Mobile /cygdrive/c/Users/Public/eclipse_workspace/accumulo_1.4.0_tag
$ mvn clean package
[INFO] Scanning for projects...
[INFO] Reactor build order:
[INFO]   accumulo
[INFO]   cloudtrace
[INFO]   accumulo-start
[INFO]   accumulo-core
[INFO]   accumulo-server
[INFO]   accumulo-examples
[INFO]   examples-simple
[INFO]   accumulo-wikisearch
[INFO]   wikisearch-ingest
[INFO]   wikisearch-query
[INFO]   wikisearch-query-war
[INFO] ------------------------------------------------------------------------
[INFO] Building accumulo
[INFO]    task-segment: [clean, package]
[INFO] ------------------------------------------------------------------------
[INFO] [clean:clean {execution: default-clean}]
[INFO] Deleting C:\Users\Public\eclipse_workspace\accumulo_1.4.0_tag\target
[INFO] Deleting C:\Users\Public\eclipse_workspace\accumulo_1.4.0_tag\lib (includes = [*.jar],
excludes = [])
[INFO] Deleting C:\Users\Public\eclipse_workspace\accumulo_1.4.0_tag\test (includes = [**/*.so],
excludes = [])
[INFO] Deleting C:\Users\Public\eclipse_workspace\accumulo_1.4.0_tag (includes = [**/*.pyc],
excludes = [])
[INFO] [enforcer:enforce {execution: enforce-mvn}]
[INFO] [remote-resources:process {execution: default}]
[INFO] [dependency:copy-dependencies {execution: copy-dependencies}]
[INFO] [exec:exec {execution: user-manual}]
docs/src/user_manual/build.sh: line 2: $'\r': command not found
docs/src/user_manual/build.sh: line 17: $'\r': command not found
docs/src/user_manual/build.sh: line 18: $'\r': command not found
: No such file or directorysh: line 20: cd: docs/src/user_manual
: No such file or directorysh: line 21: cd: /cygdrive/c/Users/Public/eclipse_workspace/accumulo_1.4.0_tag
docs/src/user_manual/build.sh: line 22: $'\r': command not found
docs/src/user_manual/build.sh: line 43: syntax error near unexpected token `$'\r''
'ocs/src/user_manual/build.sh: line 43: `)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Command execution failed.

Embedded error: Process exited with an error: 2(Exit value: 2)
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5 seconds
[INFO] Finished at: Wed Dec 19 12:09:05 EST 2012
[INFO] Final Memory: 44M/354M
[INFO] ------------------------------------------------------------------------

Nik@PTech-Mobile /cygdrive/c/Users/Public/eclipse_workspace/accumulo_1.4.0_tag
$
{noformat}

Any chance you can look at it today?  I need to get this done today.

                
> Accumulo branch 1.4.0 from SVN won't build with maven
> -----------------------------------------------------
>
>                 Key: ACCUMULO-916
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-916
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.4.0
>            Reporter: Pete Carlson
>
> Having problems building Accumulo branch 1.4 in Eclipse Juno using Maven.  Trying to
build code to match the examples we have in our Accumulo 1.4 install on our Amazon EC2 RHEL
6.3 64-bit instance.  
> Basically I'm trying to build the baseline Accumulo 1.4 code in Eclipse, and then tweak
one of the example Java files and upload the new Jar file to our Accumulo 1.4 instance.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message