accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pete Carlson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-911) Get ClassNotFoundException when running Accumulo 1.4.0 Bulk Ingest Example
Date Mon, 17 Dec 2012 19:36:21 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13534213#comment-13534213
] 

Pete Carlson commented on ACCUMULO-911:
---------------------------------------

I also tried adding the -libjars switch which gives me an error about opening the job jar:

{noformat}
[root@ip-10-151-7-8 accumulo-1.4.0]# ./bin/tool.sh
Usage: tool.sh path/to/myTool.jar my.tool.class.Name [-libjars my1.jar,my2.jar]
[root@ip-10-151-7-8 accumulo-1.4.0]# ./bin/tool.sh -libjars /lib/examples-simple-*[^c].jar
org.apache.accumulo.examples.simple.mapreduce.bulk.BulkIngestExample cybersa zookeeper1 root
**** test_bulk bulk tmp/bulkWork
Exception in thread "main" java.io.IOException: Error opening job jar: /lib/examples-simple-*[^c].jar
        at org.apache.hadoop.util.RunJar.main(RunJar.java:90)
Caused by: java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(ZipFile.java:131)
        at java.util.jar.JarFile.<init>(JarFile.java:150)
        at java.util.jar.JarFile.<init>(JarFile.java:87)
        at org.apache.hadoop.util.RunJar.main(RunJar.java:88)
[root@ip-10-151-7-8 accumulo-1.4.0]#
{noformat}
                
> Get ClassNotFoundException when running Accumulo 1.4.0 Bulk Ingest Example
> --------------------------------------------------------------------------
>
>                 Key: ACCUMULO-911
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-911
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Pete Carlson
>
> Trying to follow the steps in the README.bulkIngest for Accumulo 1.4.0 but get a ClassNotFound
Exception.  Has anyone else seen this?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message