accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-80) Refactor ScannerOptions to just use a map of iterators
Date Tue, 18 Dec 2012 19:48:12 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-80?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher Tubbs updated ACCUMULO-80:
--------------------------------------

    Fix Version/s:     (was: 1.5.0)
    
> Refactor ScannerOptions to just use a map of iterators
> ------------------------------------------------------
>
>                 Key: ACCUMULO-80
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-80
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client, tserver
>            Reporter: Jesse Yates
>
> Based on comments in ACCUMULO-53 ScannerOptions should be refactored to just having a
Map<String, IteratorSetting> mapping iterator names to iterator settings, instead of
a list and a map<scope, options>. This makes it really easy for people to add/remove
iterators.
> This involves a change to the thrift interface as well as in ScannerBase and the server
side reading of the map. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message