accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Hogue <michael.p.hogu...@gmail.com>
Subject Re: [DISCUSS] Hadoop 3 and our dependencies generally
Date Thu, 03 Aug 2017 14:18:59 GMT
All,

   For what it's worth, I'd attempted to run both 1.7.x and 1.8.x on Hadoop
3 and ran into a fairly straightforward dependency issue [1] that, when
addressed, should allow current Accumulo versions to run on Hadoop 3.
Hopefully this means that it's not a large lift to get to the point you're
aiming for.

Thanks,
Mike

[1] https://issues.apache.org/jira/browse/ACCUMULO-4611


On Thu, Aug 3, 2017 at 10:09 AM Sean Busbey <busbey@cloudera.com> wrote:

> Hi Folks!
>
> I think we need to start being more formal in planning for Hadoop 3.
> They're up to 3.0.0-alpha4 and are pushing towards API-locking betas[1].
>
> What do folks think about starting to push on an Accumulo 2.0 release that
> only supports Hadoop 3? It would let us move faster, which we'll need to do
> if we want to get any API changes in to the Hadoop 3 line.
>
> If we get started soon we can probably make it parity on beta/GA status
> with the Hadoop 3 line. That would give us a beta for Accumulo Summit and
> GA by end of the year.
>
> Going to just Hadoop 3+ would also be a sufficient dependency break that we
> could do a pass updating any lagging dependencies to latest major version.
>
>
> [1]:
> https://cwiki.apache.org/confluence/display/HADOOP/Hadoop+3.0.0+release
> --
> busbey
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message