accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ctubbsii <>
Subject [GitHub] accumulo pull request #279: ACCUMULO-3238 Table.ID Namespace.ID Refactor
Date Mon, 10 Jul 2017 20:01:37 GMT
Github user ctubbsii commented on a diff in the pull request:
    --- Diff: core/src/main/java/org/apache/accumulo/core/client/impl/ ---
    @@ -100,50 +106,150 @@ private static ZooCache getZooCache(Instance instance) {
         return namespaceMap;
    -  public static boolean exists(Instance instance, String namespaceId) {
    +  public static boolean exists(Instance instance, Namespace.ID namespaceId) {
         ZooCache zc = getZooCache(instance);
         List<String> namespaceIds = zc.getChildren(ZooUtil.getRoot(instance) + Constants.ZNAMESPACES);
    -    return namespaceIds.contains(namespaceId);
    -  }
    -  public static String getNamespaceId(Instance instance, String namespace) throws NamespaceNotFoundException
    -    String id = getNameToIdMap(instance).get(namespace);
    -    if (id == null)
    -      throw new NamespaceNotFoundException(null, namespace, "getNamespaceId() failed
to find namespace");
    -    return id;
    +    return namespaceIds.contains(namespaceId.canonicalID());
    +  /**
    +   * @deprecated Do not use - String for namespace ID is not type safe. Use {@link #getNamespaceName(Instance,
    +   */
    +  @Deprecated
       public static String getNamespaceName(Instance instance, String namespaceId) throws
NamespaceNotFoundException {
         String namespaceName = getIdToNameMap(instance).get(namespaceId);
         if (namespaceName == null)
           throw new NamespaceNotFoundException(namespaceId, null, "getNamespaceName() failed
to find namespace");
         return namespaceName;
    +  /**
    +   * @deprecated Do not use - Not type safe, ambiguous String-String map. Use {@link
    +   */
    +  @Deprecated
    --- End diff --
    I see the name was changed in order to preserve the old method as deprecated, but since
it can be removed in favor of the new method (no need to deprecate internal-only APIs), the
original name can be preserved with the new behavior. Granted, the name isn't spectacularly
clever, but it was very convenient in that it was very descriptive.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

View raw message