accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joshelser <...@git.apache.org>
Subject [GitHub] accumulo issue #237: ACCUMULO-3521: minor improvements to iterators
Date Mon, 03 Apr 2017 18:30:20 GMT
Github user joshelser commented on the issue:

    https://github.com/apache/accumulo/pull/237
  
    > Isn't that something that Deprecation does? Tells users to use at your own risk
    
    Verbatim from JDK8
    
    "A program element annotated @Deprecated is one that programmers are discouraged from
using, typically because it is dangerous, or because a better alternative exists. Compilers
warn when a deprecated program element is used or overridden in non-deprecated code."
    
    Personally, I wouldn't call the OrIterator's possible code-rot/negligence, "dangerous".
IIRC, the {{o.a.a.c.i.user}} package was introduced to bridge the gap between "Iterators we
expect users to pull off the shelf" and "Iterators which YMMV using" (a nod towards SKVI not
being in public API). I think the OrIterator's lack of love is adequately advertised by not
being in {{o.a.a.c.i.user}}.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message