accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ctubbsii <>
Subject [GitHub] accumulo pull request #209: ACCUMULO-4578 release namespace lock when compac...
Date Mon, 30 Jan 2017 17:00:34 GMT
Github user ctubbsii commented on a diff in the pull request:
    --- Diff: fate/src/main/java/org/apache/accumulo/fate/ ---
    @@ -110,25 +110,36 @@ public String getTop() {
       public static class FateStatus {
         private final List<TransactionStatus> transactions;
    -    private final Map<Long,List<String>> danglingHeldLocks;
    -    private final Map<Long,List<String>> danglingWaitingLocks;
    +    private final Map<String,List<String>> danglingHeldLocks;
    +    private final Map<String,List<String>> danglingWaitingLocks;
    +    private static Map<String,List<String>> convert(Map<Long,List<String>>
danglocks) {
    --- End diff --
    Private method needs a better name and/or docs. Convert what-to-what?

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

View raw message