accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joshelser <...@git.apache.org>
Subject [GitHub] accumulo issue #160: ACCUMULO-4490: Simplify Accumulo scripts and config fil...
Date Tue, 08 Nov 2016 19:32:30 GMT
Github user joshelser commented on the issue:

    https://github.com/apache/accumulo/pull/160
  
    Thanks, Mike!
    
    One thing I just noticed is that the help/usage on `bin/accumulo` doesn't work without
the configuration files. I un-tar'ed the bin tarball and test out this command, but, having
the short-term memory of a goldfish, I forgot the usage, so I just ran:
    
    `./bin/accumulo` and got the following:
    ```
    [accumulo@jelser-accumulo-scripts-1 accumulo-2.0.0-SNAPSHOT]$ ./bin/accumulo
    The configuration files 'accumulo-env.sh' & 'accumulo-site.xml' must exist in /home/accumulo/foo/accumulo-2.0.0-SNAPSHOT/conf
    Run 'accumulo create-config' to create them or copy them from /home/accumulo/foo/accumulo-2.0.0-SNAPSHOT/conf/examples
    Follow the instructions in INSTALL.md to edit them for your environment.
    ```
    
    Granted, this does tell me what I need to do, but should the usage still be printed? Is
the lack of configuration an extraordinary case in which the normal usage shouldn't be printed?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message