accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From keith-turner <>
Subject [GitHub] accumulo issue #145: ACCUMULO-4376 add KeyBuilder
Date Thu, 01 Sep 2016 20:18:44 GMT
Github user keith-turner commented on the issue:
    > I have to disagree in removing the column from the column components. It may be easier
for who knows Accumulo but not for the new developer and being used to see columnFamily or
colFam everywhere would make this choice particularly difficult imho for no reasons.
    @melrief  those are valid points.  There are definitely two classes of users to consider,
new users and experienced users.  I am thinking about making the code pleasant to read and
write for more experienced users and you want to make the code easier to read/write for new
users.   They are both valid concerns.  Do you think having shorter names and good javadocs
on the methods would be good enough for both users?
    > I don't understand why the newBuilder() method. What problem does it solve?
    Not much.  It offers the following advantages :
     * One less class in public API.   The interfaces need to be in public API, but with this
static method the class implementing the interfaces can be package private.
     * When a developer is looking at the Key class methods in an IDE, it makes it easy to
discover that a builder exists.  This could also be accomplished with good javadoc for Key
that points to the Builder. 

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

View raw message