accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher <ctubb...@apache.org>
Subject Re: Minimum supported Hadoop?
Date Fri, 03 Jun 2016 04:09:47 GMT
Yeah, me either... but it does raise the question: if we can't provide
proper Kerberos support (ITs don't even pass, IIRC) using a dependency
older than 2.6.1, how much can we really say 1.7.2 works on those older
versions?

On Thu, Jun 2, 2016 at 11:50 PM Mike Drob <mdrob@mdrob.com> wrote:

> I would not feel comfortable bumping the min req Hadoop in 1.7.2
>
> On Wed, Jun 1, 2016 at 6:39 PM Christopher <ctubbsii@apache.org> wrote:
>
> > Perhaps. But the tests pass with 2.6.1, I think. Shouldn't be that much
> > different in terms of support, so I figured go with the minimum we can
> test
> > with. FWIW, this affects 1.7.2 also, but i figured a bump there would be
> > more controversial.
> >
> > On Wed, Jun 1, 2016, 19:22 Josh Elser <josh.elser@gmail.com> wrote:
> >
> > > For that reasoning, wouldn't bumping to 2.6.4 be better (as long as
> > > Hadoop didn't do anything screwy that they shouldn't have in a
> > > maintenance release...)
> > >
> > > I have not looked at deltas between 2.6.1 and 2.6.4
> > >
> > > Christopher wrote:
> > > > I was looking at the recently bumped tickets and noticed
> > > > https://issues.apache.org/jira/browse/ACCUMULO-4150
> > > >
> > > > It seems to me that we may want to make our minimum supported Hadoop
> > > > version 2.6.1, at least for the 1.8.0 release.
> > > >
> > > > That's not to say it won't work with other versions... just that it's
> > not
> > > > something we're testing for in the latest release, and isn't
> > recommended
> > > > (and possibly, a downstream packager may need to patch Accumulo to
> > > support
> > > > the older version).
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message