accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From z11373 <z11...@outlook.com>
Subject Re: question on data block cache
Date Fri, 22 Jan 2016 19:22:38 GMT
Another observation which I really want to know why.

I see 1 tablet server consistently shows high number of waiting scans, i.e.
'16 (435)' or '14 (476)' on Running Scans column, while the other 19 tablet
servers all showing '0 (0)' or sometimes showing single digit number. The
thing I don't understand is what I've seen from the Monitor UI for a table
at one snapshot for example, and this is more or less consistent from time
to time (when the test clients are still running).

Server | Query | Running Scans
====================
TServer1 | 24 | 0 (0)
TServer2 | 37 | 0 (0)
TServer3 | 40 | 0 (0)
TServer4 | 1 | 0 (0)
TServer5 | 0 | 0 (0)
TServer6 | 57 | 0 (0)
TServer7 | 5 | 0 (0)
TServer8 | 4 | 0 (0)
TServer9 | 7 | 0 (0)
TServer10 | 0 | 0 (0)
TServer11 | 56 | 0 (0)
TServer12 | 124 | 0 (0)
TServer13 | 25 | 0 (0)
TServer14 | 121 | 16 (435)
TServer15 | 36 | 0 (0)
TServer16 | 21 | 0 (0)
TServer17 | 3 | 0 (0)
TServer18 | 107 | 0 (0)
TServer19 | 21 | 0 (0)
TServer20 | 92 | 0 (0)

I'd really appreciate if someone could explain what may have happened, or
can point me to the right direction for starting the investigation. For the
record, there are 50 test clients, each may create multiple scanners to
query different data from that table.

Thanks,
Z



--
View this message in context: http://apache-accumulo.1065345.n5.nabble.com/question-on-data-block-cache-tp15906p15934.html
Sent from the Developers mailing list archive at Nabble.com.

Mime
View raw message