accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "THORMAN, ROBERT D" <rt2...@att.com>
Subject Re: Review Request 33085: ACCUMULO-3652 Refactor for slf4j with concatenated strings
Date Fri, 10 Apr 2015 20:14:54 GMT
I'd like to do a pull request also but I don't have credentials to push my branch to the git
repo.

Sent from my iPhone

On Apr 10, 2015, at 3:12 PM, Christopher Tubbs <ctubbsii-rb@apache.org<mailto:ctubbsii-rb@apache.org>>
wrote:

This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/33085/


On April 10th, 2015, 12:35 p.m. EDT, Mike Drob wrote:

I think there's more in this review than just the log statements. I see changes for adding
guava Predicate, which makes me think your branch point got screwed up somewhere.

On April 10th, 2015, 12:44 p.m. EDT, Bob Thorman wrote:

Yeah, I'm using review board for the first time here.  I did a 'git describe ACCUMULO-3652'
and the used the revision number to do a 'rbt post <revision>'.  I had already merged
with master and created my patch so that is probably why all the other changes are included.
 I tried to use 'git diff' but the file would not upload.

On April 10th, 2015, 1:16 p.m. EDT, Bob Thorman wrote:

I tried 'git diff --full-index ACCUMULO-3652 origin/master > ACCUMULO-3652.diff' and then
tried to update the diff in reviewboard but got the following error.




error: unable to find 2fca41a0286b711c5d95e0fe544378230053e9ae fatal: git cat-file 2fca41a0

On April 10th, 2015, 1:17 p.m. EDT, Bob Thorman wrote:

I haven't pushed my branch back to the repo.  Is that required for reviewboard?

On April 10th, 2015, 1:28 p.m. EDT, Christopher Tubbs wrote:

Try rebasing your patch, before creating the review. I've found the rbt tools to be quite
poorly documented, so I haven't successfully used them myself. You could try just attaching
your patch manually in the web interface. That's what seems to have worked best for me in
the past.

On April 10th, 2015, 2:26 p.m. EDT, Bob Thorman wrote:

I tried uploading the patch after rebaseing the branch but still got an error.  I think both
of these approaches are expecting to access my revision in the git repot as the following
error seems to indicate.




The file "server/tracer/src/main/java/org/apache/accumulo/tracer/AsyncSpanReceiver.java" (revision
fc55de6) was not found in the repository

On April 10th, 2015, 3:36 p.m. EDT, Josh Elser wrote:

Looks like rbt might have done weird stuff to the review. Set the branch to be "master" and
then try applying your patch

ReviewBoard might keep some confusing state, too, so it'd probably be best to close this review,
and create a fresh, new one. Don't forget, pull requests are an option, too, if you're more
comfortable with that (though, obviously, there's value in learning another tool, too).


- Christopher


On April 10th, 2015, 12:21 p.m. EDT, Bob Thorman wrote:

Review request for accumulo.
By Bob Thorman.

Updated April 10, 2015, 12:21 p.m.

Repository: accumulo
Description

* Replace internal PropertyFilter with Guava's Predicate.
* Preserve MockConfiguration public API by deprecating PropertyFilter

ACCUMULO-3719 Add StrictHostKeyChecking=no to default SSH options

For testing purposes, strict host key verification is probably
overkill. Disable it by default. Users can still override
this on their own if they are concerned about security implications.

Merge branch '1.6'


Merge remote-tracking branch 'github/ACCUMULO-3714'


ACCUMULO-2131 while statement used as if statement. Changed the while to an if.

Signed-off-by: Christopher Tubbs <ctubbsii@apache.org<mailto:ctubbsii@apache.org>>

ACCUMULO-3718 make Mutation#hashCode and Mutation#equals not change the state of the mutation


Merge branch '1.5' into 1.6


Merge branch '1.6'


Merge branch 'master' of https://git-wip-us.apache.org/repos/asf/accumulo into ACCUMULO-3652


Diffs

  *   core/src/main/java/org/apache/accumulo/core/cli/ClientOpts.java (6185419f0f0913b7a875cbdc608339881f4e77dd)
  *   core/src/main/java/org/apache/accumulo/core/client/impl/ClientContext.java (9257a1ffbd0e216953c687949d16a6bfe2a41e3c)
  *   core/src/main/java/org/apache/accumulo/core/client/mock/MockConfiguration.java (8c57c5e6c2868d10e73b41cbb1b1f94fc64eb4b5)
  *   core/src/main/java/org/apache/accumulo/core/conf/AccumuloConfiguration.java (14d68c203497ea541db61c59562b004372aed085)
  *   core/src/main/java/org/apache/accumulo/core/conf/ConfigurationCopy.java (8326725e53ce18847f9dd920a2bf8076c6469ca3)
  *   core/src/main/java/org/apache/accumulo/core/conf/DefaultConfiguration.java (17364a7662391842f33b0a29abe84e22a30ef4a9)
  *   core/src/main/java/org/apache/accumulo/core/conf/SiteConfiguration.java (b410cf72e7c4f062b3607170d25ce89ce07dd35e)
  *   core/src/main/java/org/apache/accumulo/core/data/Mutation.java (ed51204279db2d194691b74b2885ada0cf3096e9)
  *   core/src/main/java/org/apache/accumulo/core/iterators/system/SourceSwitchingIterator.java
(6c401762e4ce441753b3a04ba00481ba2a333011)
  *   core/src/test/java/org/apache/accumulo/core/client/impl/ClientContextTest.java (494eb50d4feee985269fa286bdfc869f5e278e0e)
  *   core/src/test/java/org/apache/accumulo/core/conf/DefaultConfigurationTest.java (e21db3d19d7a1bfad59a53d7a753a52ae27c0025)
  *   core/src/test/java/org/apache/accumulo/core/conf/ObservableConfigurationTest.java (b92fac6fb7692dc70e42eca7fca46ffd37f5a48b)
  *   core/src/test/java/org/apache/accumulo/core/conf/SiteConfigurationTest.java (f54adb15054cd0d53938ad383fbc20f4790279ac)
  *   core/src/test/java/org/apache/accumulo/core/data/MutationTest.java (6607c6e841b51b21ad5c326856e594b192a88aab)
  *   minicluster/src/main/java/org/apache/accumulo/cluster/RemoteShellOptions.java (714096e16ade1ef44d1888c603c80ec11fc26a71)
  *   server/base/src/main/java/org/apache/accumulo/server/conf/NamespaceConfiguration.java
(bae694bdcb41874be37f0cb1d57f7e96118cd100)
  *   server/base/src/main/java/org/apache/accumulo/server/conf/TableConfiguration.java (259f2a2d7f197aa2766a1a0ac69bfa00cc469d09)
  *   server/base/src/main/java/org/apache/accumulo/server/conf/ZooCachePropertyAccessor.java
(bec30d299f0675d67dbb156ea05ed4d9f6817f39)
  *   server/base/src/main/java/org/apache/accumulo/server/conf/ZooConfiguration.java (a53350ba285b3b2029c99c6faa38d50f37877a30)
  *   server/base/src/main/java/org/apache/accumulo/server/fs/PreferredVolumeChooser.java
(77026e6af9da9958faf33daec56deced8658fd59)
  *   server/base/src/test/java/org/apache/accumulo/server/conf/NamespaceConfigurationTest.java
(6bd6424242d012a163ed22b0c6f652e879c0336d)
  *   server/base/src/test/java/org/apache/accumulo/server/conf/TableConfigurationTest.java
(68ee2b98bdda332a2c8aa5a432ac1aee03f62d40)
  *   server/base/src/test/java/org/apache/accumulo/server/conf/ZooCachePropertyAccessorTest.java
(210d24047b04d9a1692204bb9b4e4b7b984d1019)
  *   server/base/src/test/java/org/apache/accumulo/server/util/FileUtilTest.java (5fe35f9f43331f49b59bf66004b09d2148ee0888)
  *   test/src/test/java/org/apache/accumulo/test/util/CertUtils.java (3bbd7377a787585e0bf1102c43075a86243f3a71)

View Diff<https://reviews.apache.org/r/33085/diff/>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message