accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher <ctubb...@apache.org>
Subject Maven 3.3 requires JDK 1.7+
Date Thu, 19 Mar 2015 15:23:24 GMT
Hi all,

This is just a heads-up that Maven 3.3 and later requires JDK 1.7 or
later. This is something to be aware of, because it means that
building Accumulo could become a lot more complicated if trying to use
the latest version of Maven. Incidentally, there's some good
documentation on how to set up toolchains on the Maven site[1].
However, I'm not really that interested in setting up toolchains in
the POM (because it would force all our developers to set up their
build environment with them). It's probably easier if we just slowly
migrated away from JDK versions earlier than 1.7 (which, given that
the master branch requires 1.7, we're already moving towards).

What this means for Accumulo:

...regarding developing: develop using whatever works for you, but
keep in mind that releases will need to be built more strictly.

...regarding releases: I'd recommend building Accumulo 1.6.x and
earlier releases using the latest Java 6 JDK and the latest Maven 3.2
version. For building Accumulo 1.7.0 and later, I recommend using the
latest Java 7 JDK and the latest version of Maven (currently 3.3.1).

There's nothing to be done, really. For most people, this information
isn't going to change anything. I just wanted to make sure people were
aware of where the build tools were headed, and how they might impact
Accumulo builds / releases.

[1]: http://maven.apache.org/guides/mini/guide-using-toolchains.html

--
Christopher L Tubbs II
http://gravatar.com/ctubbsii

Mime
View raw message