accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher <ctubb...@apache.org>
Subject Re: Client on host can't connect to Accumulo in Docker instance
Date Tue, 16 Dec 2014 05:42:12 GMT
bin/accumulo shell -z <instanceName> <zkHosts>
or
bin/accumulo shell -zi <instanceName> -zh <zkHosts>



--
Christopher L Tubbs II
http://gravatar.com/ctubbsii

On Tue, Dec 16, 2014 at 12:07 AM, David Medinets <david.medinets@gmail.com>
wrote:
>
> Can you please specific the settings?
>
> On Mon, Dec 15, 2014 at 8:22 PM, Christopher <ctubbsii@apache.org> wrote:
> > Oh yes, you can definitely use the shell to connect to a MAC instance.
> Just
> > use the ZK params to the shell. I do it all the time to debug
> long-running
> > ITs.
> >
> >
> > --
> > Christopher L Tubbs II
> > http://gravatar.com/ctubbsii
> >
> > On Mon, Dec 15, 2014 at 6:54 PM, David Medinets <
> david.medinets@gmail.com>
> > wrote:
> >>
> >> Can I use the accumulo shell with the MiniAccumuloCluster? That's an
> >> interesting idea. I did not think it feasible.
> >>
> >> On Mon, Dec 15, 2014 at 6:48 PM, Christopher <ctubbsii@apache.org>
> wrote:
> >> > Have you tried the Accumulo shell with --debug?
> >> >
> >> >
> >> > --
> >> > Christopher L Tubbs II
> >> > http://gravatar.com/ctubbsii
> >> >
> >> > On Mon, Dec 15, 2014 at 6:45 PM, David Medinets <
> >> david.medinets@gmail.com>
> >> > wrote:
> >> >>
> >> >> I just remembered that Zookeeper can respond to "ruok" so I did try
> >> >> that. It worked:
> >> >>
> >> >> $ echo "ruok" | netcat -q 2 localhost 20000; echo ""
> >> >> imok
> >> >>
> >> >> On Mon, Dec 15, 2014 at 6:18 PM, David Medinets
> >> >> <david.medinets@gmail.com> wrote:
> >> >> > The MAC running in Docker is starting and seems to run fine. A
> client
> >> >> > program inside the Docker instance can create tables and add
> splits.
> >> >> > However, a client running on the host, just hangs when connecting.
> I'm
> >> >> > not seeing any errors in the log files.
> >> >> >
> >> >> > I can connect to the Monitor running inside the Docker instance
so
> the
> >> >> > ports should all be open.
> >> >> >
> >> >> > Any recommendations where I should look to resolve this?
> >> >>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message