accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject Connection Refused Reading Instance Id From HDFS
Date Wed, 09 Jul 2014 14:12:53 GMT
I'm hoping someone has a few minutes to help debug this networking issue.
I'm running a single-node Accumulo 1.5.1 instance (using Hadoop 2.4) inside
Docker. I can find the Accumulo instance id manually:

-bash-4.1# hdfs dfs -ls /accumulo/instance_id
Found 1 items
-rw-r--r--   1 accumulo accumulo          0 2014-07-09 08:22
/accumulo/instance_id/9421cd33-5f37-4f6d-b645-372feb431cae

But when the gc tries to find the instance id, I see this message in the
log file:

-bash-4.1# cat
/var/log/supervisor/accumulo-gc-stdout---supervisor-nwDCZU.log
2014-07-09 09:04:07,006 [client.ZooKeeperInstance] ERROR: Problem reading
instance id out of hdfs at /accumulo/instance_id
java.net.ConnectException: Call From grail/172.17.0.2 to grail:8020 failed
on connection exception: java.net.ConnectException: Connection refused;

The hostname is 'grail' which resolves to 172.17.0.2 via /etc/hosts and it
can ping itself:

david@zareason-verix545:~/projects/docker-builds/accumulo$ ./enter_image.sh
grail
-bash-4.1# ping grail
PING grail (172.17.0.2) 56(84) bytes of data.
64 bytes from grail (172.17.0.2): icmp_seq=1 ttl=64 time=0.083 ms
64 bytes from grail (172.17.0.2): icmp_seq=2 ttl=64 time=0.054 ms

Do I need to use IP addresses in the 'gc' and other configuration files?

Any ideas for me to try?

When the NameNode starts, the log file has no errors. It starts with:

STARTUP_MSG: Starting NameNode
STARTUP_MSG:   host = grail/172.17.0.2

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message