accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject Re: Monitor finding wrong hostname
Date Wed, 09 Jul 2014 15:46:48 GMT
Thanks. After updating the accumulo-env.sh the process is pulling from
IPV4. But I have no idea why the hostname is being reported as 'namenode'
instead of 'grail'.

java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.apache.accumulo.start.Main$1.run(Main.java:103)
    at java.lang.Thread.run(Thread.java:744)
Caused by: java.net.UnknownHostException: namenode
    at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)
    at java.net.InetAddress$1.lookupAllHostAddr(InetAddress.java:901)
    at
java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1293)
    at java.net.InetAddress.getAllByName0(InetAddress.java:1246)
    at java.net.InetAddress.getAllByName(InetAddress.java:1162)

I've updated the github project with my latest attempt.


On Wed, Jul 9, 2014 at 11:21 AM, Josh Elser <josh.elser@gmail.com> wrote:

> Actually, we do, and he isn't :)
>
> https://github.com/medined/docker-builds/blob/master/
> accumulo/accumulo.conf/accumulo-env.sh
>
> David, update your accumulo-env.sh. You also have cruft in there that is
> no longer necessary (e.g. ACCUMULO_LOG_HOST)
>
>
> On 7/9/14, 11:18 AM, Sean Busbey wrote:
>
>> Josh and I are talking about this config at the end of hte
>> ACCUMULO_GENERAL_OPTS in the example accumulo-env.sh[1]:
>>
>> -Djava.net.preferIPv4Stack=true
>>
>>
>> [1]:
>> https://github.com/apache/accumulo/blob/1.5.1/conf/examples/512MB/native-
>> standalone/accumulo-env.sh#L52
>>
>>
>> On Wed, Jul 9, 2014 at 10:16 AM, Sean Busbey <busbey@cloudera.com> wrote:
>>
>>  Sure, but we don't know if David's current configs include everything
>>> from
>>> the examples.
>>>
>>>
>>> On Wed, Jul 9, 2014 at 10:11 AM, Josh Elser <josh.elser@gmail.com>
>>> wrote:
>>>
>>>  I think I had made the change before 1.5.1 came out which updates the
>>>> example configs to set the JVM preferIpv4Stack (or w/e that option is),
>>>> too.
>>>>
>>>>
>>>> On 7/9/14, 10:37 AM, Sean Busbey wrote:
>>>>
>>>>  The stacktrace shows it's trying to use IPv6.
>>>>>
>>>>> Have you disabled ipv6 on the host? Do your Accumulo role options
>>>>> include
>>>>> the flag that says to use the ipv4 network stack?
>>>>>
>>>>>
>>>>>
>>>
>>> --
>>> Sean
>>>
>>>
>>
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message