accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vicky Kak <vicky....@gmail.com>
Subject Re: Accumulo shell remote debugger settings.
Date Sun, 15 Jun 2014 20:04:15 GMT
Having the debugger port open by default would be a software crime ;)


On Mon, Jun 16, 2014 at 1:33 AM, Vicky Kak <vicky.kak@gmail.com> wrote:

> Ah Sorry I meant not to enable it by default i.e
> I am **not** suggesting that we should make the remote debugging enabled
> by default but have the other property for the shell command which does not
> collide with the generic properties
>
> I would propose to have ACCUMULO_SHELL_OPTS without the debugger ports by
> default.
>
>
>
> On Mon, Jun 16, 2014 at 1:21 AM, Josh Elser <josh.elser@gmail.com> wrote:
>
>> I'm not completely sold that we should be enabling them by default. I
>> think
>> it would create more confusion and problems for the average user.
>> Additionally, with the proposed ACCUMULO_SHELL_OPTS, you have the ability
>> to easily enable them for yourself.
>>
>> With the configuration generation tool included with 1.6.0, I could see
>> options that allow you to enable the ports too.
>> On Jun 15, 2014 9:32 AM, "Vicky Kak" <vicky.kak@gmail.com> wrote:
>>
>> > Yes that is correct, the ports are going to collide.
>> > I am suggesting that we should make the remote debugging enabled by
>> default
>> > but have the other property for the shell command which does not collide
>> > with the generic properties
>> >
>> >
>> > On Sun, Jun 15, 2014 at 7:58 PM, Josh Elser <josh.elser@gmail.com>
>> wrote:
>> >
>> > > I think Vicky is just noting that each process would have to be
>> defined
>> > > individually and not use ACCUMULO_GENERAL_OPTS  as the debugger ports
>> > would
>> > > collide.
>> > >
>> > > I think making an ACCUMULO_SHELL_OPTS is fine.
>> > > On Jun 15, 2014 8:38 AM, "William Slacum" <
>> > wilhelm.von.cloud@accumulo.net>
>> > > wrote:
>> > >
>> > > > Putting the flag in the process/module OPTs is fine. It's what I
>> > normally
>> > > > do when I want to debug. Are you suggesting we have remote debugging
>> > > > enabled by default?
>> > > >
>> > > >
>> > > > On Sun, Jun 15, 2014 at 9:11 AM, Vicky Kak <vicky.kak@gmail.com>
>> > wrote:
>> > > >
>> > > > > While trying to get the remote debugger running with accumulo
I
>> > figured
>> > > > > that for the accumulo shell command we need to introduce the
>> > following
>> > > > > changes
>> > > > >
>> > > > > 1) test -z "$ACCUMULO_SHELL_OPTS"   && export
>> > > > ACCUMULO_SHELL_OPTS="-Xmx128m
>> > > > > -Xms64m
>> > -Xrunjdwp:server=y,transport=dt_socket,address=4002,suspend=n"
>> > > > >
>> > > > > in accumulo-env.sh
>> > > > >
>> > > > > 2)
>> > > > > include the additional case in accumulo.sh
>> > > > >
>> > > > > shell)  export ACCUMULO_OPTS="${ACCUMULO_GENERAL_OPTS}
>> > > > > ${ACCUMULO_SHELL_OPTS}" ;;
>> > > > >
>> > > > > We can't define the debugger port in the $ACCUMULO_OTHER_OPTS
in
>> the
>> > > > > accumulo-env.sh as that would be bind when start-all.sh is called.
>> > > > >
>> > > > > Before I raise a JIRA for this a provide a patch I would like
to
>> hear
>> > > the
>> > > > > option from others how they enable the remote debugging for the
>> shell
>> > > > > command.
>> > > > >
>> > > > > Thanks,
>> > > > > Vicky
>> > > > >
>> > > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message