accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: RAT plugin - change to package phase
Date Wed, 21 May 2014 00:47:35 GMT
Pretty much.

On 5/20/14, 8:15 PM, dlmarion@comcast.net wrote:
> Figured it out, I'm in 1.6.1 and the mapreduce and shell modules are empty, so Eclipse
tried to fix them. I guess they are new in 1.7.0, and this is a side effect of switching back
and forth?
>
>
> ----- Original Message -----
>
> From: dlmarion@comcast.net
> To: dev@accumulo.apache.org
> Sent: Tuesday, May 20, 2014 8:07:12 PM
> Subject: Re: RAT plugin - change to package phase
>
>
> Looking closer at the rat.txt, appears to be issues with shell and mapreduce modules.
Here is the top of the file:
>
> *****************************************************
> Summary
> -------
> Generated at: 2014-05-20T20:04:16-04:00
> Notes: 4
> Binaries: 239
> Archives: 0
> Standards: 157
>
> Apache Licensed: 143
> Generated Documents: 0
>
> JavaDocs are generated and so license header is optional
> Generated files do not required license headers
>
> 12 Unknown Licenses
>
> *******************************
>
> Unapproved licenses:
>
> mapreduce/.project
> mapreduce/.settings/org.eclipse.jdt.core.prefs
> mapreduce/.settings/org.eclipse.m2e.core.prefs
> mapreduce/.settings/org.eclipse.core.resources.prefs
> mapreduce/target/classes/META-INF/MANIFEST.MF
> mapreduce/.classpath
> shell/.project
> shell/.settings/org.eclipse.jdt.core.prefs
> shell/.settings/org.eclipse.m2e.core.prefs
> shell/.settings/org.eclipse.core.resources.prefs
> shell/target/classes/META-INF/MANIFEST.MF
> shell/.classpath
>
>
> ----- Original Message -----
>
> From: "Christopher" <ctubbsii@apache.org>
> To: "Accumulo Dev List" <dev@accumulo.apache.org>
> Sent: Tuesday, May 20, 2014 7:47:11 PM
> Subject: Re: RAT plugin - change to package phase
>
> Validate is the default for the plugin. The reason this runs so early
> is because ASF policy for license headers only applies to source, not
> generated classes in the build.
>
> If it's failing for you, it's probably because your workspace is
> dirty... try "git clean -fdx" to clean your workspace (careful to
> stage any added new files you'd like to keep first with 'git add').
>
> If this is not the case, I'd like to try to figure out why this is
> happening for you, and not others, rather than change the default set
> by the plugin.
>

Mime
View raw message