accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs" <ctubb...@apache.org>
Subject Re: Review Request 21639: ACCUMULO-2808 Update to Jetty 9
Date Wed, 21 May 2014 05:00:36 GMT


> On May 21, 2014, 12:46 a.m., Josh Elser wrote:
> > LGTM. Would be good to make sure we can still build/test/run against Hadoop1 before
applying though (slf4j changes)

I actually built with the default (hadoop 2) profile and ran against Hadoop 1.2.1 in the manual
run I described above.


- Christopher


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/21639/#review43589
-----------------------------------------------------------


On May 19, 2014, 1:31 p.m., Christopher Tubbs wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/21639/
> -----------------------------------------------------------
> 
> (Updated May 19, 2014, 1:31 p.m.)
> 
> 
> Review request for accumulo and Bill Havanki.
> 
> 
> Bugs: ACCUMULO-2808
>     https://issues.apache.org/jira/browse/ACCUMULO-2808
> 
> 
> Repository: accumulo
> 
> 
> Description
> -------
> 
> This patch updates Jetty for the monitor service to version 9.
> 
> The patch was made from the 1.6.0 release tag, because I need it for downstream packaging
of 1.6.0, but the target version is for the next major Accumulo release (I expect that to
be 2.0.0 when the community finalizes that release plan). So, to test this patch, check out
1.6.0 and apply. I will, of course, address any merge conflicts before pushing to the target
branch.
> 
> This patch incorporates the packaging goals of ACCUMULO-2786 also, but only for future
major releases where we're willing to bump the dependency version. I don't expect this will
be sufficient for that ticket for any 1.6.x bugfix release.
> 
> 
> Diffs
> -----
> 
>   assemble/pom.xml 9ebd2de 
>   assemble/src/main/assemblies/component.xml 747444b 
>   conf/templates/accumulo-site.xml 052ed7e 
>   pom.xml 43aa5fb 
>   server/monitor/pom.xml ccc455e 
>   server/monitor/src/main/java/org/apache/accumulo/monitor/EmbeddedWebServer.java 1eeb04e

>   start/pom.xml ee288a3 
>   test/pom.xml 5d12ba6 
> 
> Diff: https://reviews.apache.org/r/21639/diff/
> 
> 
> Testing
> -------
> 
> 1. Successfully executed 'mvn clean verify -Psunny'
> 
> 2. Manually ran a patched instance of 1.6.0, both with and without SSL enabled, and verified
that the service was listening on the correct host/port and that I could connect to it in
the browser and traverse links. There was no change in the behavior from what I have come
to expect from before the patch.
> 
> 
> Thanks,
> 
> Christopher Tubbs
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message