accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: compatibility check between 1.5.x and 1.6.0?
Date Wed, 23 Apr 2014 06:27:24 GMT
Here's the current reports, built with japi-compliance-checker 1.3.6

http://people.apache.org/~busbey/compat_reports/accumulo/

executed with:

for version in 1.5.0 1.5.1 1.5.2; do japi-compliance-checker
-skip-deprecated -old japi-accumulo-${version}.xml -new
japi-accumulo-1.6.xml -l accumulo; done

with the config xmls like what's in the repo, but set to look in my maven
repo and to not skip mock.

I'll triage the 1.5.0 changes tomorrow



On Tue, Apr 22, 2014 at 9:04 PM, Eric Newton <eric.newton@gmail.com> wrote:

> I believe Keith did a mechanical/manual analysis and brought back a couple
> of methods/classes.
>
> -Eric
>
>
> On Tue, Apr 22, 2014 at 8:46 PM, Sean Busbey <busbey@cloudera.com> wrote:
>
> > Has anyone done a compatibility check for the public API between 1.5.x
> and
> > 1.6.0?
> >
> > While looking into ACCUMULO-2722 I noticed some changes that might be
> > problematic in client.mock and was wondering if anyone did a larger sweep
> > already.
> >
> > --
> > Sean
> >
>



-- 
Sean

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message